const regex = /(^|[^\d,.])0+(\d+)\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^|[^\\d,.])0+(\\d+)\\b', 'g')
const str = `102
1,03
1.03
004
05
06+07
08/09
010,10,01
00,01
0001
01*01
010,0
0,0000001
5/0`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);