re = /(^|[^\d,.])0+(\d+)\b/
str = '102
1,03
1.03
004
05
06+07
08/09
010,10,01
00,01
0001
01*01
010,0
0,0000001
5/0'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result