$re = '/hello|world/m';
$str = 'hello
world
abc
helloworld
he
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);