const regex = /^(?:\d*;){1}(\d*);/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:\\d*;){1}(\\d*);', 'gm')
const str = `99999;88888;22222;33333;44444;55555;66666;00000;12312;34534;56756`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}