$re = '/^([0-9a-zA-Z])(?!.*\1$)[0-9a-zA-Z]{5,}$/m';
$str = 'abcdef
abcdea';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);