$re = '/^[^\/]+\/([^\s;]+)/';
$str = 'text/html; text/xml; text/json';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);