re = /(<td(?=.*?class="MID")[^>]*>(?:(?!<\/td>).)*<\/td>)/
str = '<td width="33%" align="left" class="MID">
<a href="ShowDOTCoByState.cfm?STATE=US&PHY_ST=IA">IOWA</a>
</td>
<td width="33%" align="left">
<a href="ShowDOTCoByState.cfm?STATE=US&PHY_ST=IA">IOWA</a>
</td>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end