import Foundation
let pattern = #"(<td(?=.*?class="MID")[^>]*>(?:(?!<\/td>).)*<\/td>)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
<td width="33%" align="left" class="MID">
<a href="ShowDOTCoByState.cfm?STATE=US&PHY_ST=IA">IOWA</a>
</td>
<td width="33%" align="left">
<a href="ShowDOTCoByState.cfm?STATE=US&PHY_ST=IA">IOWA</a>
</td>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)