using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @""".*?(?<!\\)""";
string input = @"This is some text, and here's some in ""double quotes""
""and here's a double quote:\"" and some more"", ""text that follows""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}