#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([0-9]+)(\s+)?(?=mA)"
Local $sString = "case 1, only number and unit: 1mA" & @CRLF & _
"case 2, number and unit, space: 1mA current" & @CRLF & _
"case 3, number and unit, punctuation: 1mA," & @CRLF & _
"case 4, number and unit, Unicode characters: 1mA电流I " & @CRLF & _
"case 1, only number and unit: 10mA" & @CRLF & _
"case 2, number and unit, space: 100mA current" & @CRLF & _
"case 3, number and unit, punctuation: 10 mA ," & @CRLF & _
"case 4, number and unit, Unicode characters: 1000 mA电流I "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")