# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([0-9]+)(\s+)?(?=mA)"
test_str = ("case 1, only number and unit: 1mA\n"
"case 2, number and unit, space: 1mA current\n"
"case 3, number and unit, punctuation: 1mA,\n"
"case 4, number and unit, Unicode characters: 1mA电流I \n"
"case 1, only number and unit: 10mA\n"
"case 2, number and unit, space: 100mA current\n"
"case 3, number and unit, punctuation: 10 mA ,\n"
"case 4, number and unit, Unicode characters: 1000 mA电流I ")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.