package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*?chr(.*?)\.recalibrated.*`)
var str = `output.chr10.recalibrated
output.chr11.recalibrated
output.chrY.recalibrated`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}