import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?ms)(^NAME.*?)^\\s+^\\d";
final String string = "SQL*Plus: Release 11.2.0.1.0 Production on Wed Jan 27 13:46:07 2016\n\n"
+ "Copyright (c) 1982, 2010, Oracle. All rights reserved.\n\n\n"
+ "Connected to:\n"
+ "Oracle Database 11g Enterprise Edition Release 11.2.0.3.0 - 64bit Production\n"
+ "With the Partitioning, Real Application Clusters, Automatic Storage Management, OLAP,\n"
+ "Data Mining and Real Application Testing options\n\n\n"
+ "NAME\n"
+ "--------------------------------------------------------------------------------\n"
+ "Agent-Job Follow Up Missed Group D\n"
+ "Agent-Job Follow Up Missed Group E\n"
+ "Audit Archive\n"
+ "Day BGO - 705 and 705NA - A (2)\n"
+ "Day BGO - ERR Quebec - A\n"
+ "Dispatch Lunch Break Agent (Pre-Agent) - Group D\n"
+ "Helper Job Agent (Amend, Prevent, Lead) Group A\n"
+ "Incomplete Tasks Display Status Cleanup - Group A\n"
+ "Jeopardy Agent (Late EnRoute, OnSite, Complete) Group A\n"
+ "Jeopardy Agent (Late EnRoute, OnSite, Complete) Group B\n"
+ "Lunch Break Report Agent(Post-Agent) - Group A\n\n"
+ "NAME\n"
+ "--------------------------------------------------------------------------------\n"
+ "MST Validation - Group A\n"
+ "MST Validation - Group C\n"
+ "Unschedule INHS Tasks\n"
+ "Unschedule Jobs with Schedule Update Failure - Group E\n\n"
+ "15 rows selected.\n\n"
+ "Disconnected from Oracle Database 11g Enterprise Edition Release 11.2.0.3.0 - 64bit Production\n"
+ "With the Partitioning, Real Application Clusters, Automatic Storage Management, OLAP,\n"
+ "Data Mining and Real Application Testing options";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}