import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(da|en-gb|en|\\*))(?!.*\\1(?!-))(?:;q=(?:1|0(\\.\\d+)?))?(?:,(da|en-gb|en|\\*)(?!.*\\3(?!-))(?:;q=(?:1|0(?:\\.\\d+)?))?)*";
final String string = "enenen-gben\n\n"
+ "enenenen-gb\n\n"
+ "Accept-Language: da, en-gb;q=0.8, en;q=0.7\n"
+ "en;q=0,da;q=0.4,*;q=0.4,da;q=0.4";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}