$re = '/(?<=\|)[^|]*\|[^|]*$/m';
$str = '[[Basel]] |key_people = [[Axel A. Weber]] (Chairman){{br}}[[Sergio
Ermotti]] (CEO) {{br}} |area_served = Worldwide |industry =[[Banking]], [[Financial services]] |products = [[Investment Banking]]';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;