import re
regex = re.compile(r"var .*?Scope.*?=[\s\S]*?{([\s\S]*?)};[\s\S]*?var .*?Directive.*?=[\s\S]*?{([\s\S]*?)};[\s\S]*?encModule.directive\(['\"](.*?)['\"][\s\S]*")
test_str = ("//------------------------------------------------------------------\n"
"// PrivacyAgreementDialogDirective.js\n"
"// Copyright 2013 AppliedMinds, Inc.\n"
"//------------------------------------------------------------------\n\n"
"\"use strict\";\n\n"
"//------------------------------------------------------------------\n"
"// Map of attributes to be copied into the scope.\n"
"var privacyAgreementDialogScope =\n"
"{\n"
"};\n\n"
"//------------------------------------------------------------------\n"
"// Configuration of the privacyAgreementDialog directive.\n"
"var privacyAgreementDialogDirective =\n"
"{\n"
" 'restrict' : 'E',\n"
" 'transclude' : true,\n"
" 'scope' : privacyAgreementDialogScope,\n"
" 'controller' : 'PrivacyAgreementDialogCtrl',\n"
" 'templateUrl' : 'encirca/common/privacyAgreementDialog/PrivacyAgreementDialog.html',\n"
" 'replace' : true\n"
"};\n\n"
"//------------------------------------------------------------------\n"
"// Create the directive.\n"
"encModule.directive('privacyAgreementDialog',\n"
" enc.func.returns(privacyAgreementDialogDirective));\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")