import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "site[.]com\\/[^\\/]+\\/(\\d+)";
final String string = "site.com/cat/36814-antonov-polnaya-ahineya.html\n"
+ "site.com/80-90/36460-dobrynin-polnaya-ahineya.html\n"
+ "site.com/cat/4415-pyryshki.html";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}