$re = '/^([2-9]|[1-4][0-9]|50)$/m';
$str = '51
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);