import Foundation
// WARNING: You included a flag that Swift doesn't support: U
// When this flag is set, it inverts the "greediness" of the quantifiers so that they are not greedy by default, but become greedy if followed by '?'.
// As an alternative, this effect can also be achieved by setting a (?U) modifier setting within the pattern or by a question mark behind a quantifier (e.g. .*?).
let pattern = #"(?:Blabla\(2\) :|(?<!^)\G).*<tr><td class=\"generic\">(.*)<\/td>.+<\/tr>"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.caseInsensitive, .dotMatchesLineSeparators])
let testString = #"2019-09-25 22:26:47.283 ERROR 2296 --- [prod-upload-9] c.a.s.t.t.service.TrendyolServiceImpl : Failed to upload 3539007 reason is could not predict the category automatically, please fill in the field aliexpress_category_id: Req: {"adminLoginId":"tr1333351585hxnn","aggregationId":"3539007","description":"<ul> \n <li>Ürünlerimiz sağlığa zararlı kimyasallara karşı test edilmektedir.Ürünlerimizde bebeklerin yutabileceği küçük parçalar, tehlike oluşturabilecek ip ve kordonlar, keskin parçalar bulunmamaktadır. 2'Li Kız Bebek Desenli Mendil</li> \n</ul>","externalSkulInfoDTOList":[{"price":"399","skuAttributesList":[{"skuAttributeName":"Color","skuAttributeValue":"Ekru/03E","skuImage":"https://img-trendyol.mncdn.com/Assets/ProductImages/oa/60/4260756/1/8681976357811_1_org_zoom.jpg"},{"skuAttributeName":"Size","skuAttributeValue":"One Size"}],"skuCode":"8681976357811","stock":0}],"grossWeight":"1","language":"tr","mainImagesList":["https://img-trendyol.mncdn.com/Assets/ProductImages/oa/60/4260756/1/8681976357811_1_org_zoom.jpg"],"merchantBrandName":"Koton Kids","merchantCategoryId":"373_1","merchantCategoryName":"Mendil","packageHeight":30,"packageLength":10,"packageWidth":20,"subject":"Koton Kids Ekru Kız Bebek 2'Li Kiz Bebek Desenli Mendil","thirdPartyDomain":"TRENDYOL"}"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)