#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ui)([\p{L}.'-+]+@(?:[a-z0-9.\-\p{L}]+.)+(?:[a-zA-Z0-9-\p{L}]{2,24}))"
Local $sString = "<p>Тест@домен.ком</p>" & @CRLF & _
"Тест@домен.ком" & @CRLF & _
"test@domain.com" & @CRLF & _
"γλώσσα@τομέας.com" & @CRLF & _
"<p>моят-тестов@пример.bg</p>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")