import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\p{L}.'-+]+@(?:[a-z0-9.\\-\\p{L}]+.)+(?:[a-zA-Z0-9-\\p{L}]{2,24}))";
final String string = "<p>Тест@домен.ком</p>\n"
+ "Тест@домен.ком\n"
+ "test@domain.com\n"
+ "γλώσσα@τομέας.com\n"
+ "<p>моят-тестов@пример.bg</p>";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}