#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)[\]a-zA-Z0-9]\[([^\.\]]+)\]([\[a-zA-Z0-9])?"
Local $sString = "should pass" & @CRLF & _
"$test[2]" & @CRLF & _
"" & @CRLF & _
"$test.var2[4]" & @CRLF & _
"$test[0].var3.var4" & @CRLF & _
"$test[30].var5[30][3333].var6" & @CRLF & _
"$test[0].var7[3][4]" & @CRLF & _
"$test[0].var8.var9.var10" & @CRLF & _
"" & @CRLF & _
"below should not pass" & @CRLF & _
"$test.var1" & @CRLF & _
"$test.var1.asd" & @CRLF & _
"test[]" & @CRLF & _
"test [0]" & @CRLF & _
"test/[0]" & @CRLF & _
"test/[0]/" & @CRLF & _
"test.[0]" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")