use strict;
my $str = 'should pass
$test[2]
$test.var2[4]
$test[0].var3.var4
$test[30].var5[30][3333].var6
$test[0].var7[3][4]
$test[0].var8.var9.var10
below should not pass
$test.var1
$test.var1.asd
test[]
test [0]
test/[0]
test/[0]/
test.[0]
';
my $regex = qr/[\]a-zA-Z0-9]\[([^\.\]]+)\]([\[a-zA-Z0-9])?/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}