// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)[\]a-zA-Z0-9]\[([^\.\]]+)\]([\[a-zA-Z0-9])?").unwrap();
let string = "should pass
$test[2]
$test.var2[4]
$test[0].var3.var4
$test[30].var5[30][3333].var6
$test[0].var7[3][4]
$test[0].var8.var9.var10
below should not pass
$test.var1
$test.var1.asd
test[]
test [0]
test/[0]
test/[0]/
test.[0]
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}