$re = '/(?<!http:\/\/)(?=www)/m';
$str = 'http://www.google.com
www.google.com';
$subst = "http://";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;