#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[[:alnum:]éè ]+$"
Local $sString = "@test" & @CRLF & _
"test123é" & @CRLF & _
"abcdA" & @CRLF & _
"13465" & @CRLF & _
"éè 123test" & @CRLF & _
"_this-is" & @CRLF & _
"this_is"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")