import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((https?|ftp):\\/\\/)?([a-z0-9+!*(),;?&=.-]+(:[a-z0-9+!*(),;?&=.-]+)?@)?([a-z0-9\\-\\.]*)\\.(([a-z]{2,4})|([0-9]{1,3}\\.([0-9]{1,3})\\.([0-9]{1,3})))(:[0-9]{2,5})?(\\/([a-z0-9+%-]\\.?)+)*\\/?(\\?[a-z+&$_.-][a-z0-9;:@&%=+/.-]*)?(#[a-z_.-][a-z0-9+$%_.-]*)?";
final String string = "rew ewrwe http://192.168.1.100:10/\n"
+ "erewrw ew 192.168.1.100/1e rwerrewdsfsdf \n"
+ "werew rrew we vk.com we ewr werw\n"
+ " erewr http://vk.com/ ewrwe\n"
+ "ewrew https://vk.com/ werew\n"
+ "www.vk.com\n"
+ "my age is : 60. and ...\n"
+ "ятх.рф\n"
+ "ыщьу ... dfggd\n\n"
+ "Служу в армии?\n"
+ "Еще целый год терпеть это убожество\n"
+ "Ростом 1.90 см?\n"
+ "За остальным в л.с :)\n\n"
+ "http://test.test-75.1474.stackoverflow.com/\n"
+ "https://www.stackoverflow.com\n"
+ "https://www.stackoverflow.com/\n"
+ "http://wwww.stackoverflow.com/\n"
+ "http://wwww.stackoverflow.com\n\n\n"
+ "http://test.test-75.1474.stackoverflow.com/\n"
+ "http://www.stackoverflow.com\n"
+ "http://www.stackoverflow.com/\n"
+ "stackoverflow.com/\n"
+ "stackoverflow.com\n\n"
+ "http://www.example.com/etcetc\n"
+ "www.example.com/etcetc\n"
+ "example.com/etcetc\n"
+ "user:pass@example.com/etcetc\n\n"
+ "example.com/etcetc?query=aasd\n"
+ "example.com/etcetc?query=aasd&dest=asds\n\n"
+ "http://stackoverflow.com/questions/6427530/regular-expression-pattern-to-match-url-with-or-without-http-www\n"
+ "http://stackoverflow.com/questions/6427530/regular-expression-pattern-to-match-url-with-or-without-http-www/\n"
+ "my age is: 60. and ...";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}