package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d{0,}\.(\d{0,})`)
var str = `0.6666666666666666`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}