package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)<ul.*?">(.*?)<\/ul>`)
var str = `<div id="outer">
<ul id="ancTop">
<li style="font-family: arial; font-size: 9pt;">
<div style="overflow: hidden; width: 690px; height: 17px;">
<a href="#">
A90 - Lorem Ipsum
</a>
</div>
</li>
<li style="font-family: arial; font-size: 9pt;">
<div style="overflow: hidden; width: 690px; height: 17px;">
<a href="#">
A85 - Lorem Ipsum
</a>
</div>
</li>
</ul>
</div>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}