use strict;
my $str = '<div id="outer">
<ul id="ancTop">
<li style="font-family: arial; font-size: 9pt;">
<div style="overflow: hidden; width: 690px; height: 17px;">
<a href="#">
A90 - Lorem Ipsum
</a>
</div>
</li>
<li style="font-family: arial; font-size: 9pt;">
<div style="overflow: hidden; width: 690px; height: 17px;">
<a href="#">
A85 - Lorem Ipsum
</a>
</div>
</li>
</ul>
</div>';
my $regex = qr/<ul.*?">(.*?)<\/ul>/sp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}