import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\d\\(][\\(\\)\\s\\.\\-\\d]{4,}\\d)";
final String string = "whatever 0 (000) 000-0000 whatever whatever 0(000)000-0000 whatever\n"
+ "whatever (000) 000-0000 whatever whatever (000)000-0000 whatever\n"
+ "whatever 000 000-0000 whatever whatever 000.000.0000 whatever\n"
+ "whatever 000-42000-0000 whatever whatever 000-0000 whatever\n"
+ "whatever 000 - 0000 whatever whatever 000.0000 whatever\n"
+ "whatever 000 . 0000 whatever whatever 000 0000 whatever 1\n"
+ "whatever 00000000000 whatever\n"
+ "whatever 0000000000 whatever\n"
+ "whatever 000000000 whatever\n"
+ "whatever 00000000 whatever\n"
+ "whatever 0000000 whatever\n"
+ "whatever 000000 whatever\n"
+ "whatever 00 00 0000 0000 whatever 3\n"
+ "whatever 00 0000 000 000 whatever 3\n"
+ "whatever 000 0000 0000 whatever 2\n"
+ "whatever (000) 0000 0000 whatever\n"
+ "whatever 00000 000000 whatever 1\n"
+ "whatever 00 0000 0000 whatever 21135";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}