$re = '/([\d\(][\(\)\s\.\-\d]{4,}\d)/';
$str = 'whatever 0 (000) 000-0000 whatever whatever 0(000)000-0000 whatever
whatever (000) 000-0000 whatever whatever (000)000-0000 whatever
whatever 000 000-0000 whatever whatever 000.000.0000 whatever
whatever 000-42000-0000 whatever whatever 000-0000 whatever
whatever 000 - 0000 whatever whatever 000.0000 whatever
whatever 000 . 0000 whatever whatever 000 0000 whatever 1
whatever 00000000000 whatever
whatever 0000000000 whatever
whatever 000000000 whatever
whatever 00000000 whatever
whatever 0000000 whatever
whatever 000000 whatever
whatever 00 00 0000 0000 whatever 3
whatever 00 0000 000 000 whatever 3
whatever 000 0000 0000 whatever 2
whatever (000) 0000 0000 whatever
whatever 00000 000000 whatever 1
whatever 00 0000 0000 whatever 21135';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);