package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<option.*?\s(?:selected(?:=\"selected\")?)\s.*?>`)
var str = `<option selected="selected" value="1">value text</option>
<option selected value="1">value text</option>
<option value="the devil with **selected** ">value text</option>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}