re = /<option.*?\s(?:selected(?:=\"selected\")?)\s.*?>/
str = '<option selected="selected" value="1">value text</option>
<option selected value="1">value text</option>
<option value="the devil with **selected** ">value text</option>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end