package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:.*?HALL.*?){2,}`)
var str = `HALL #1 HALL #2 HALL #3`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}