const regex = new RegExp('[^0-9]+', 'g')
const str = `9(35) 3465-4553`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);