use strict;
my $str = '9(35) 3465-4553';
my $regex = qr/[^0-9]+/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";