const regex = /(https?:\/\/)(.+?)([a-z-]*)\/?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(https?:\\\/\\\/)(.+?)([a-z-]*)\\\/?$', 'gm')
const str = `https://something.com/a/lomg/ur-l/
http://something.com/a/lomg/url
https://something.com/a/lomg/url/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}