import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[(quote)\\]?\\s*(?:author)?=?(\\S+)*";
final String string = "[quote author=username link=1150111054/0#7 date=1150151926][/quote]\n\n"
+ "[quote] username link=1142890417/0#43 date=1156429613]This is a very simple test sentence.[/quote]\n\n"
+ "[quote=user name pid=123456]\n"
+ "Test.[/quote]\n\n"
+ "[quote] user name link=1142890417/0#43 date=1156429613][quote] username link=1142890417/0#43 date=1156429613]This is a very simple test sentence.[/quote]\n"
+ "This is a very simple test sentence.[/quote]\n";
final String subst = "[$1=$2]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}