const regex = /\[(quote)\]?\s*(?:author)?=?(\S+)*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[(quote)\\]?\\s*(?:author)?=?(\\S+)*', 'gm')
const str = `[quote author=username link=1150111054/0#7 date=1150151926][/quote]
[quote] username link=1142890417/0#43 date=1156429613]This is a very simple test sentence.[/quote]
[quote=user name pid=123456]
Test.[/quote]
[quote] user name link=1142890417/0#43 date=1156429613][quote] username link=1142890417/0#43 date=1156429613]This is a very simple test sentence.[/quote]
This is a very simple test sentence.[/quote]
`;
const subst = `[$1=$2]`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);