$re = '/(-?[0-9]+(?:[,.][0-9]+)?)/m';
$str = '123
-123.21
0.1
123
H3.07LLo my nam3 is bob12';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);