#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "Subject :\s*([\s\S]*?)(?=\*+end of input\*+)"
Local $sString = "Subject :" & @CRLF & _
"" & @CRLF & _
"So for example, one field can span any number of lines and then there will be a message similar to" & @CRLF & _
"****end of input****" & @CRLF & _
"" & @CRLF & _
"It will match anything after the colon until it hits a new line character. This works for almost all of the fields I need to scrape. One however, is a bit more trouble. One of them, the last one I need to scrape (not shown above) will span multiple lines. There's no way to predict how long it will be, but instead I have another predefined piece of text I can use to determine where to stop capturing."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")