$re = '/([\"])[a-zA-Z\s]+([\"])/m';
$str = 'fo bar baz "some word"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);