// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^([0-9]{9}[0-9X]|[A-Za-z][\dA-Za-z]{9})\.([A-Z0-9]{4})\.PC_([0-9]{3})\.jpg$").unwrap();
let string = "B12345678X.MAIN.PC_042.jpg";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}