using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\B([A-Z]+)";
string substitution = @" $1";
string input = @"ABC";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}