const regex = /\B([A-Z]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\B([A-Z]+)', 'g')
const str = `ABC`;
const subst = ` $1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);