$re = '/\((?<name>[^)]+)\)\((?<type>\d+)\)\((?<percent>[^)]+)\)(?:\((?<who>[^)]+)\))?/';
$str = '(name)(123)(percent)(who)
(name)(123)(percent)
(cgfddfv fl)(3)(yo 15 %)(vk.com/sda)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);