import Foundation
let pattern = #"(["'])((?:(?=(?:\\)*)\\.|.)*?)\1"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
" RegExp to match quotes "
' Supports escapin\' '
" This is selected \\" this is not
' Works with JS RegExp '
"You can also get the quote type used"
"How it works"
"------------"
' (["\']) Matches a " or a \' and stores it in \1'
' ( starts \2'
' (?: starts a non-capturing group'
' (?=(?:\\)*) Will check if there is an odd amount of \ '
' \\. will escape / ignore it '
' |. will never mind it if there\'s an even amount '
' )*? will close the non-capturing group and repeat it'
' \1 will make it close with the quote selected in \1'
"Flags:"
"------"
" g: global, selects multiple times "
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)