$re = '/^([2-2]{1}|[6-7]{1})([0-9]{3})[-. ]?(\d{4})?$/';
$str = '78511074';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);