# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*?\b(\d{2})\.(\d{2})\.(\d{4})\b/\3\2\1/;t' <<< "Campaign on 01.11.2015"